I have often found it difficult to find commands that actually work because it seems that Dell Switch commands not only differ by OS version but can also vary based on the model, and of course, I do not rule out that there may be some differences according to the firmware version.
This is a copy-paste from Dell EMC Networking – RDMA over Converged Ethernet (RoCE v2) Cheat Sheet RoCE v2 Configuration cheat sheet with Dell EMC OS10 Dell EMC S4112T-ON (OS10)
This guide covers basic configurations for enabling features like LLDP, DCBX, and ETS on a Dell EMC S4112T-ON switch running OS10, with a focus on setting up RDMA over Converged Ethernet (RoCE v2).
What is RDMA over Converged Ethernet
Enable LLDP
Switch# conf
Switch(conf)# lldp enable
Switch(conf-lldp)# end
Switch#
Enable DCBX
Switch# conf
Switch(conf)# dcbx en
Switch(conf)#
Turn on ETS
Switch(config)# system qos
Switch(config-sys-qos)# ets mode on
Switch(config-sys-qos)# end
Switch#
Configure the QoS-Map
Match the queues to the CoS values, 0 (LAN), 4 (iSCSI), and 5 (RDMA).
Switch# conf t
Switch(config)# qos-map traffic-class qmap
Switch(config-qos-map)# queue 0 qos-group 0-3,6-7
Switch(config-qos-map)# queue 5 qos-group 5
Switch(config-qos-map)# queue 4 qos-group 4
Switch(config-qos-map)# end
Switch#
Configure Class Maps
Queueing
This queues refer to the queues configured in step 4.
Switch# conf t
Switch(config)# class-map type queueing q0
Switch(config-cmap-queuing)# match queue 0
Switch(config-cmap-queuing)# exit
Switch(config)# class-map type queuing q4
Switch(config-cmap-queuing)# match queue 4
Switch(config-cmap-queuing)# exit
Switch(config)# class-map type queuing q5
Switch(config-cmap-queuing)# match queue 5
Switch(config-cmap-queuing)# exit
Switch(config)#
Network-QoS
This class map is used for service policy input and applied as ingress traffic.
Switch# conf t
Switch(config)# class-map type network-qos iSCSI
Switch(config-cmap-nqos)# match qos-group 4
Switch(config-cmap-nqos)# exit
Switch(config)# class-map type network-qos RoCEv2
Switch(config-cmap-nqos)# match qos-group 5
Switch(config-cmap-nqos)# end
Switch#
Configure Policy Maps
ETS Policy Map
Assigning bandwidth percentage to each queue.
Switch# conf t
Switch(config)# policy-map type queuing q1
Switch(config-pmap-queuing)# class q0
Switch(config-pmap-c-que)# bandwidth percent 10
Switch(config-pmap-c-que)# exit
Switch(config-pmap-queuing)# class q4
Switch(config-pmap-c-que)# bandwidth percent 40
Switch(config-pmap-c-que)# exit
Switch(config-pmap-queuing)# class q5
Switch(config-pmap-c-que)# bandwidth percent 50
Switch(config-pmap-c-que)# end
Switch#
PFC Policy Map
Policy map turning PFC “ON” on CoS 4 and 5 for iSCSI and RDMA flows respectively.
Switch# conf t
Switch(config)# policy-map type network-qos PFC_ON
Switch(config-pmap-network-qos)# class iSCSI
Switch(config-pmap-c-nqos)# pause
Switch(config-pmap-c-nqos)# pfc-cos 4
Switch(config-pmap-c-nqos)# exit
Switch(config-pmap-network-qos)# class RoCEv1
Switch(config-pmap-c-nqos)# pause
Switch(config-pmap-c-nqos)# pfc-cos 5
Switch(config-pmap-c-nqos)# end
Switch#
Applying Policy Maps to Interfaces
Switch# conf t
Switch(config# inte ethe1/1/5
Switch(config-if-eth1/1/5)# switchport mode trunk
Switch(config-if-eth1/1/5)# switchport trunk allowed vlan 100,200,300
Switch(config-if-eth1/1/5)# service-policy input type network-qos PFC_ON
Switch(config-if-eth1/1/5)# service-policy output type queuing q1
Switch(config-if-eth1/1/5)# ets mode on
Switch(config-if-eth1/1/5)# qos-map traffic-class qmap
Switch(config-if-eth1/1/5)# priority-flow-control mode on
Switch(config-if-eth1/1/5)# end
Switch#
This configuration setup ensures your switch supports various network protocols effectively, tailored to manage RDMA, iSCSI, and general LAN traffic through differentiated services.
PDF File